Connecting Problems With Home Wireless Networks

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

Connecting Problems With Home Wireless Networks

Postby printmkr » Wed Jan 02, 2008 9:29 pm

Hi I am using 653, and I have a WEP and a WPA network to test with (WPA is one a green smoothwall firewall segment and WEP on a purple firewall segment.) My question is, though it admittedly does not add that much protection, is it possible to use the XO without broadcasting the SSID of the networks? Thanks for any help.
printmkr
 
Posts: 6
Joined: Wed Jan 02, 2008 9:11 pm

accessing the internet

Postby Dian » Wed Jan 02, 2008 11:38 pm

I have tried the OLPC connecting networking instructions, I have activated the upgrade (653) and still no connection. I have determined my router uses WEP. I have tried accessing the wireless network with through a WRT54GX2 and GT704WG router. Is this the problem?
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby peter » Thu Jan 03, 2008 2:13 am

Dian. Are you able to connect to your router in other words, does nm-tool have a * beside your SSID? Are your getting an IP addresses starting with 169.254.x.x (bad).

I have heard where for WEP, the XO will only accept the hexadecimal version of your key.

[url="http://ei4web.yz.yamagata-u.ac.jp/%7Ekinouchi/cgi-bin/ASCIItoHEX.html"]Try this ASCII to hexadecimal conversion link[/url]. Type in your password in regular text, and it will return the hex equivalent. Try using that instead of your key.
Simiya - For Lovers of Caribbean Art
peter
 
Posts: 182
Joined: Sun Nov 20, 2005 10:56 pm

Postby Dian » Thu Jan 03, 2008 8:25 am

When I logged onto to the xo this morning I noticed I now have no IP address. Last night when I contacted you I did have an IP address starting with 169... and I did have the *. Today I have none. I tried the conversion from the ascii to the hexidecimal. It doesn't work. When the xo asks for the password to access the internet it wants it in passphrase(128-bit). That is when I use the down arrow and input the hex code. Still no luck.
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby ektoric » Thu Jan 03, 2008 5:48 pm

Dian;772 wrote:When the xo asks for the password to access the internet it wants it in passphrase(128-bit).

Dian, Please check your router's WEP options. Try to see if it is 128bit or 40bit. Also verify if it is Open or Shared (usually Open).

On the olpc, when you try to connect, make sure the olpc settings match the router's. In other words, suppose the router is 40bit. On the olpc, click on the "passphrase 128bit" area and drop down to choose the "ascii 40bit" selection before entering in your key.
ektoric
Support Team
 
Posts: 470
Joined: Wed Jan 02, 2008 3:46 pm
Location: Austin, TX

Postby Purplekat » Thu Jan 03, 2008 5:48 pm

My fiance solved the problem of my not being able to connect to our WPA network in a different way. I'm not exactly sure how he did it, but he made an exception for my XO in the encryption, so that it was able to bypass having to enter a password, while the network still stays encrypted for other computers -- my laptop sees it as encrypted, but my XO doesn't.

If you guys think it would be helpful, I can try and talk him into signing in here and posting an explanation of how he did this.
Purplekat
 
Posts: 19
Joined: Fri Dec 28, 2007 3:15 pm

Postby Dian » Thu Jan 03, 2008 6:24 pm

I am not sure how to find out if it is 128 or 40 bit. I do know it is SSID enabled. I do know my ip address for my router is 192.168.1.102. I have tried to contact at Starbucks and at friend's house with a wireless router. The ip address on the xo i check nm-tool is 169.254.9.52. Not sure what to do? Help
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby peter » Thu Jan 03, 2008 7:14 pm

Do you know the SSID the router is using? I assume you do, but am just checking.

It seems odd that you are having failures when trying this at so many different places.
Simiya - For Lovers of Caribbean Art
peter
 
Posts: 182
Joined: Sun Nov 20, 2005 10:56 pm

Postby Dian » Thu Jan 03, 2008 7:31 pm

Yes on my computer the SSID is linksys. Check out the following, i did it and it did not work:

Dian,

Can you try reviewing the below FAQ? It is a new FAQ targeted at this
issue, and I think it may help:

[URL="http://wiki.laptop.org/go/Support_FAQ#How_do_I_disable_automatic_connection_to_my_Access_Point.3F"]http://wiki.laptop.org/go/Support_FAQ#How_do_I_disable_automatic_connection_to_m
y_Access_Point.3F
[/URL]

- Casey -

Volunteer Support
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby peter » Thu Jan 03, 2008 11:39 pm

All Linksys routers default to "linksys" as their SSID, unless you change it. Have you checked to see whether you are in an area with multiple linksys routers or which yours is only one of many?

You may be trying to connect to the wrong one. Try hovering over all the routers / access points in your neighborhood view and see if this is so.
Simiya - For Lovers of Caribbean Art
peter
 
Posts: 182
Joined: Sun Nov 20, 2005 10:56 pm

Postby Dian » Thu Jan 03, 2008 11:47 pm

I am sure it is mine. There are others in the neighborhood with specific names. I am still thinking it has something to do with the ip address. I wish I knew how to change it on the xo.
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby peter » Thu Jan 03, 2008 11:53 pm

The XO should receive it's IP address from the router, but only after it get's past the wireless password part.

Does nm-tool show a * (asterisk / star) beside any of the SSIDs it sees? It only has a star beside the SSID of the router to which it successfully connects.
Simiya - For Lovers of Caribbean Art
peter
 
Posts: 182
Joined: Sun Nov 20, 2005 10:56 pm

Postby Dian » Fri Jan 04, 2008 12:24 am

It shows an asterick by my SSID.
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Postby peter » Fri Jan 04, 2008 12:38 am

So it looks like your wireless router isn't set up for giving out anymore IP addresses.

Try logging into its Web GUI and see how you can expand the range of addresses it gives out or activate IP address assignments. The option may be listed in the menus by its technical term, DHCP.

I think in the Linksys interface it would be under the "basic setup" menu. The first menu you see when you log in.

This is what I have on mine. I only give out 7 addresses. To be safe, set the starting IP address to a number like 192.168.1.200 and give out up to 50 addresses. That should be more than enough.

Code: Select all
DHCP Server:                   Enable             
Starting IP  Address:          192.168.1.248           
Maximum Number of  DHCP Users: 7
Simiya - For Lovers of Caribbean Art
peter
 
Posts: 182
Joined: Sun Nov 20, 2005 10:56 pm

Postby Dian » Fri Jan 04, 2008 1:17 am

I am talking to the linksys chat line now. I hope to get help. I still don't understand why I cannot access the internet at other locations then my home. Can my problem really be fixed?? Still trying.
Dian
 
Posts: 11
Joined: Wed Jan 02, 2008 11:27 pm

Next

Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 1 guest