Backing out of Wpa.sh

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

Backing out of Wpa.sh

Postby BradandRhonda » Fri Feb 01, 2008 9:46 pm

I ran the script Wpa.sh a few times with no luck.
See http://wiki.laptop.org/go/WPA_Manual_Setting
I want to back out of the changes.
Can anyone confirm that deleting the
/home/olpc/.sugar/default/nm/networks.cfg
file is the way to undo the script.
I found this within the forum
Code: Select all
$ rm /home/olpc/.sugar/default/nm/networks.cfg

from http://en.forum.laptop.org/viewtopic.php?f=1329&t=150829#p528534

I know zero linux but remember some DOS and editng autoexec.bat and config.sys from a long, long, long time ago. I assume this is just a remove file command.
BradandRhonda
 
Posts: 10
Joined: Sun Jan 27, 2008 7:57 pm

Re: Backing out of Wpa.sh

Postby Ben James Ben » Fri Feb 01, 2008 11:27 pm

Yes. The Wpa.sh script just adds some lines to networks.cfg. Please note that if you run Wpa.sh more than once, you end up adding more and more lines into networks.cfg. And, if you mess up running Wpa.sh (by entering something wrong), you could end up with invalid config information in the file which could cause networking problems.

Deleting the networks.cfg file is probably the easiest way to back out the Wpa.sh changes. Please note that doing so also deletes all the other stuff that happened to be in the file before you ran Wpa.sh. However, if you are having networking problems, it is probably best to just delete networks.cfg entirely to start over with a completely clean config.
Ben James Ben
 
Posts: 32
Joined: Sat Jan 26, 2008 10:10 pm

Re: Backing out of Wpa.sh

Postby BradandRhonda » Sat Feb 02, 2008 7:43 am

Thanks Ben. I pulled the rm command from one of your posts.

Can you give me some simple commands for edit and save for the network.cfg file. Is there a text editor in terminal or do you use the write activity.
BradandRhonda
 
Posts: 10
Joined: Sun Jan 27, 2008 7:57 pm

Re: Backing out of Wpa.sh

Postby Ben James Ben » Sat Feb 02, 2008 10:48 am

From the Terminal or Console, there are two editing programs that are available on the XO, that I am aware of: vi and nano.

vi is the one I use. It's found on most Unix-based systems, which makes it versatile. However, it is difficult to learn. Here are three vi tutorials, if you are interested: 1, 2, 3

nano is the one I recommend you use. It is much easier to learn. You might even be able to use it without having to read the tutorial, since it has built-in help functions. nano is a clone of pico, so looking at pico tutorials might also be helpful: 1, 2, 3.

Code: Select all
$ cd /home/olpc/.sugar/default/nm
$ nano networks.cfg
Ben James Ben
 
Posts: 32
Joined: Sat Jan 26, 2008 10:10 pm

Re: Backing out of Wpa.sh

Postby BradandRhonda » Sat Feb 02, 2008 8:38 pm

Thanks. VI will give me a flashback to my first e-mail.
BradandRhonda
 
Posts: 10
Joined: Sun Jan 27, 2008 7:57 pm

Re: Backing out of Wpa.sh

Postby Infamy » Tue Feb 12, 2008 10:49 am

BradandRhonda,

It sounds like you are still running 650. Upgrading to 656 should solve your WPA issues(it even autoconnects for me)

-Infamy
1st day donor :)
Infamy
Support Team
 
Posts: 168
Joined: Wed Dec 26, 2007 3:21 pm
Location: Portsmouth, NH

Re: Backing out of Wpa.sh

Postby Grandma » Tue Feb 19, 2008 3:00 am

Hi Infamy

You're always so good helping everybody.

I had the laptop working very well and even the online "learn to read" software finally working properly! I've done all of what you've told me (upgraded to built 656 and adjusted my jabber server to xochat.org). However, today I decided to switch the wireless connection from WEP to WPA and I've been unable to connect to the internet. It instantly finds my wireless network and brings up the little screen that asks for my wireless encryption key and the encryption type. When I type the 10 digit key and choose TKIP as the encryption type, it tries to connect but is unable and brings back the little screen again and again. Any suggestions as to what could be the problem?

I checked wiki and found that I could do a WPA Manual setting by going to Terminal and typing the following, substituting the values for ssid and passphrase (and then press the "Enter" key):

/usr/sbin/wpa_passphrase <ssid> <passphrase>

It kept giving me an error message.

Should I just go back to WEP? Is there anything I should do prior to?

THANKS once again for your cooperation.

Olga
Grandma
 
Posts: 8
Joined: Tue Feb 05, 2008 11:24 pm


Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 2 guests