wireless rate slow

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

wireless rate slow

Postby seeklinux » Sat Feb 02, 2008 5:54 pm

I guess I shouldn't complain since some appear to have trouble getting their wireless working at all, but I noticed that the wireless transfer rates are significantly slower on the XO than on my other laptops. I have a Thinkpad running Ubuntu and on it I am getting over 6Mbps while the XO is getting around 2Mbps. They are both close to the wireless router. A Mac in another room (further from the router) is getting close to 5Mbps.

The router is set up for wireless-g only and I am using WPA2.

Is this difference in speed expected? If so, due to the wireless chip? Or perhaps the processor having to do encryption for WPA2?

Anyone else experiencing this. I did notice the PC world review at http://www.pcworld.com/article/id,140931/article.html indicated wireless was very slow as well. By the way, I went to http://www.pcpitstop.com/internet/Bandwidth.asp to test the speed.

Thanks.
seeklinux
 
Posts: 2
Joined: Sat Feb 02, 2008 5:37 pm

Re: wireless rate slow

Postby seeklinux » Mon Feb 04, 2008 11:21 am

I should point out that I did upgrade to build 656 and unfortunately I did not test the download speed in the original build (650) before upgrading.
seeklinux
 
Posts: 2
Joined: Sat Feb 02, 2008 5:37 pm

Re: wireless rate slow

Postby tdang » Sat Feb 23, 2008 6:42 pm

I finally got around to comparing the speed on th XO to my Mac, and it seems a good bit slower for me, also. It's variable, but the XO might be half the speed of the Mac.

Anybody have ideas?

It has occurred to me to wonder if it's the Browse activity, I don't know for sure that speed-testing web sites are good at separating processing from connection speeds?

Thanks

-TImothy
tdang
 
Posts: 62
Joined: Fri Dec 28, 2007 9:07 pm

Re: wireless rate slow

Postby momendo » Fri Feb 29, 2008 11:59 pm

For every level of stronger encryption you use, there is a decrease in overall throughput over Wifi. It varies between chipsets and what's paired. WPA2 is slow but very secure. You could change to 40bit encryption. That would improve speeds.

I would also check the channel your router is broadcasting. If it's on channel 6, that is the default for many routers. In crowded city apartments & condos where everybody has a wireless router, it's *very* noisy and can slow down or stop your bandwidth. Load up netstumbler or some other wifi sniffer to check for free channels. If there is one, say channel 4, switch your router to that channel. There may be some improvement.
Have you given a laptop lately?
http://www.olpcusers.com
momendo
 
Posts: 5
Joined: Fri Feb 29, 2008 10:38 pm

Re: wireless rate slow

Postby XOIOWA » Sat Mar 01, 2008 11:34 am

Another thing to check is which Internet Protocol Version you are using. By default, FireFox (and Browse on the XO) use IPV6. But, most of the world (probably better than 99.9%) is still using IPV4. So, what happens is that Browse tries to find the address first as IPV6, but when it can't find it, it then looks for it as IPV4 and finds it. On minimal computers that delay is enough to really affect your browsing.

I do this on all my computers. Go to Browse, and in the title bar type this:

about:config

Press enter, and you'll get a long list of settings for the web browser. At the top of this list of settings there is a Filter where you can narrow down to the particular setting you want. In this case just type:

IPV

It will narrow the list to probably only two entries. One of those entries is this:

network.dns.disableIPv6

Double click on the word 'false' at the end of that line to change it to 'true'.

Now go wherever you want to on the internet. Your browser will only look at IPV4 addresses, which is okay, because almost nothing is using IPV6 yet. And, it isn't likely that they will start switching things over to IPV6 for a few years.
XOIOWA
 
Posts: 18
Joined: Sun Feb 24, 2008 3:24 pm


Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 2 guests

cron