Wifi Stopped Working

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

Wifi Stopped Working

Postby XOIOWA » Sun Feb 24, 2008 3:27 pm

I posted this yesterday at olpcnews forums... hoping someone reading here can help.

Hi All!

I've been reading this forum since receiving my XO in November, but just now have signed up for an account. Until now my XO has worked well with my WEP access point at my home. Today I woke up, booted the XO, and I'm not seeing any access points at all. There's nothing at all in the neighborhood view (I usually see 3-4 of my neighbors plus the mesh channels). So, I think it's a problem with wireless being disabled for some reason.

I tried to check the radio status at the terminal using this:
$ sugar-control-panel -g radio

but, I get a series of messages (I don't want to type them all here, so I'll abbreviate)
Traceback (most recent call last):
File "/usr/bin/sugar-control-panel", line 87, in <module>
main ()
File "/usr/bin/sugar-control-panel", line 74, in main
File "/usr/share/sugar/shell/controlpanel/control.py", line 313, in print_radio
print get_radio()
dbus.exceptionsDBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

I am not exactly a linux newbie, I know only enough to be dangerous. Any help in troubleshooting would be greatly appreciated. BTW, I'm running build 650, and I really don't want to upgrade yet. I haven't had any trouble with 650 until today, and I haven't done anything to the system since it was last connecting to wifi.

Posts: 18
Joined: Sun Feb 24, 2008 3:24 pm

Re: Wifi Stopped Working

Postby XOIOWA » Mon Feb 25, 2008 10:48 pm

Replying to my own post:

First, after work today I tried to boot while holding the O game button, to reset my XO to it's factory settings. I did that twice, both times it told me there was a boot failure, and that it would shut down in 10 seconds, which it did.

So, I decided to reflash. That was a learning experience in itself. I discovered that holding the O game button while powering on only works -after- you've upgraded your system. Since I was still on the 650 build, I could not do that. So, I downloaded the os650.img file and the fs.zip file and put them on a thumbdrive and did the activated upgrade instructions outlined here:

http://wiki.laptop.org/go/Activated_Upg ... ted_Laptop

Everything worked fine on that, and now I have Wifi back! Yippie! I now have a clean build 650, so I'll want to go through and make the few edits that I've done. I want to turn off the automatic frame, for instance, and get the full abiword library.

I am disappointed that I don't know what the problem was. Re-installing always seems like a band-aid fix to me. I'd rather know what caused the problem in the first place, so that I can either fix it, or avoid it. But, at this point I'm just happy to have my wifi back.
Posts: 18
Joined: Sun Feb 24, 2008 3:24 pm

Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 0 guests