WiFi works, internet doesn't

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

WiFi works, internet doesn't

Postby shkmc » Sun Apr 03, 2011 1:36 am


I'm using an XO-1 with official build 860, using GNOME, and connecting to a network that uses a ten-character WEP hex code.

I can connect to the network just fine, but I cannot use any internet programs; i.e., Firefox, Empathy IM, they all give me "server not found" or "network error" feedback. I tried pinging IP addresses on the local network, which made me think that the problem was with the DNS server. But I can ping google.com and yahoo.com just fine, so it doesn't seem that that is the case. Does anyone have any idea what could be the problem? Proxies are disabled, by the way, and I have tried deleting the network settings and re-entering them, which hasn't worked.

I first encountered the problem when I tried Debxo 0.6 on the laptop. I thought it was an OS issue, so I tried putting the official OS back on, but that hasn't fixed anything.
Posts: 1
Joined: Sun Apr 03, 2011 1:21 am

Re: WiFi works, internet doesn't

Postby ektoric » Sun Apr 03, 2011 1:53 pm

There's a command line program called "wget" that you can use to pull down a URL. For example:
Code: Select all
wget http://www.google.com

will get you Google's "index.html". If this tool succeeds, you should have in your directory a index.html that looks like google's page. If it doesn't, then there might be something wrong with your network connectivity.

You mentioned ping works. If ping works, but wget doesn't, perhaps your firewall has port 80 blocked. Alternately, if you are out at some hotspot, many times, they'll allow ping through, but block other internet access until you go to their website to "sign on".
Support Team
Posts: 470
Joined: Wed Jan 02, 2008 3:46 pm
Location: Austin, TX

Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 4 guests