Having trouble upgrading

Discuss Sugar, upgrades and developer perspectives.

Having trouble upgrading

Postby qqmm » Fri Jan 30, 2009 1:58 pm

My friend gave me a OLPC. I am trying to upgrading to 8.2.0 version. It turns off after reboot on the step #7 (http://wiki.laptop.org/go/Release_Notes/8.2.0). When I try to turn it on, a message shows:

Got firmware version: CL1 Q2E18 Q2E
Checking integrity....
Update firmware
AC not present
Power off in 10 seconds

What can I do?
Thanks
qqmm
 
Posts: 2
Joined: Fri Jan 30, 2009 1:43 pm

Re: Having trouble upgrading

Postby Nayantara » Fri Jan 30, 2009 2:21 pm

Try the no-fail update, details here http://wiki.laptop.org/go/No-fail_update
With illustrations here http://wiki.laptop.org/go/USB_upgrade
Gave 13-Nov-2007, Got 3-Jan-2008.
Nayantara
 
Posts: 60
Joined: Mon Jan 28, 2008 1:48 pm
Location: Boston Area, MA, USA

Re: Having trouble upgrading

Postby qqmm » Fri Jan 30, 2009 6:52 pm

Thanks. It works.
However, when I tried to launch an activity, its icon flashes in the middle of the screen, nothing happens. What can I do?

Thanks
qqmm
 
Posts: 2
Joined: Fri Jan 30, 2009 1:43 pm

Re: Having trouble upgrading

Postby ncarrol » Fri Jan 30, 2009 9:31 pm

Assume you followed procedure in "No-Fail_Upgrade".

Did you allow the upgrade to get the newest revisions of the activities at the end of the upgrade ?
If not do the Control Panel / Update software ( must of course be on the internet) and exit with Check mark.

Pick out one activity (say Terminal or Browse) and lets work with that activity.

I still suspect that you have corrupted software -- did the download finish correctly with no interruptions during the download ?

The XO must be fully charged and the AC power plugged in during any upgrade.
Reset the radio to make sure it is not locked. This is done by removing and then replacing the battery --- setting XO power to OFF does not turn off radio.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Having trouble upgrading

Postby kayanat » Thu Mar 12, 2009 12:55 am

Why am I having trouble upgrading my Yahoo IM? I was messaging my friend last night and was trying to send her a pic but it wouldn't work. She told me that a message came up that said I was running an older version of Yahoo IM and that I had to upgrade. Well everytime I try to upgrade it just keeps starting over again and again. Can someone help me? Do I have to uninstall my old Yahoo IM first?
kayanat
 
Posts: 1
Joined: Mon Mar 09, 2009 7:29 am


Return to Sugar, Linux and System Software

Who is online

Users browsing this forum: No registered users and 1 guest

cron