devkey and time problems

Discuss Sugar, upgrades and developer perspectives.

devkey and time problems

Postby lkregula » Thu Jan 12, 2012 8:28 pm

I've been getting an "Invalid system date" message on start up, but my XO-1 continues to boot without other problems. I'd like to correct the date so as to avoid problems later on (I lost one XO-1 to an RTC problem), but it's a secured machine right now. I've tried requesting a developer key, but when I go to request one, I get a message that the security certificate will not be good until 2010 (the date set on the computer is 1972?). How can I A) reset the clock so I can get a developer key, or B) otherwise manage to get a developer key (can I request one using my Dell laptop, e.g.)? Any help is greatly appreciated! Thanks!
Posts: 2
Joined: Sun Dec 25, 2011 7:58 pm

Re: devkey and time problems

Postby ncarrol » Thu Jan 12, 2012 10:17 pm

This is an easy one to fix.

Use the Activity terminal and set the time with the date command.

First, select Settings (or control panel for earlier software versions -- except the original version 650).
Select Date / Time . This lets you set what time zone you are in and contains a list of large cities. Scroll down to a big city in you time zone and select it.

Now go back and run Terminal Activity. Become "superuser" with the su command.
Use the date command:

date -s 20120112 for example
date -s 19:35:00 for example

Exit Terminal Activity.

To get your Developer Key, open Browse and click on the choice to request a developer key.

You have to wait 24 hours to actually get the key. You enter Browse again and click on the same choice. You will be provided with instructions for retrieving the key.

If you do not have the information in the Browser about the key, then you have an old version of software (Browse) and should update.

The reason you got the message about wait to 2010 has to do with the invalid time and the requirement to wait a day.

Why did you lose an XO to the RTC problem ? This can be fixed using a serial adapter from ($10 including shipping) to set the time or an XO can be sent to one of the community repair facilities for repair. See more info about this.
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: devkey and time problems

Postby lkregula » Thu Jan 12, 2012 10:28 pm

Thanks! I should have said "...what I thought was an RTC problem." It had the listed symptoms- blank screen, power on, mic light blinks on but doesn't stay on- but when I tried the fixes for RTC, nothing worked. I couldn't even get anything on the terminal computer when I had the XO-1 hooked up to it. Watch out for posts from me- I'm just getting started with really wanting to play with the XO-1, it seems like an awesome little critter! :lol:
Posts: 2
Joined: Sun Dec 25, 2011 7:58 pm

Return to Sugar, Linux and System Software

Who is online

Users browsing this forum: No registered users and 7 guests