Wifi Connection Cycle Tip

Share uncovered secrets, useful notes, guides and hacks!

Wifi Connection Cycle Tip

Postby Infamy » Mon Feb 11, 2008 6:40 pm

Hello All,

Not sure if this is common information for most, but here goes.

When the XO starts up, it begins a cycle of searching for connections as follows:

School Server Mesh
Access Point
Mesh Portal Point
Link Local

It always searchs in this order, and there isn't a way currently to tell it to do anything different. However, you can tell it where to start ;)

By creating the file /etc/NetworkManager/mesh-start, containing the word "infra", it will look for the last access point it was connected to.

To do this, follow these steps:

1. Start the terminal activity
2. enter: su -
3. enter: nano -w /etc/NetworkManager/mesh-start
4. Step three will start a text editor. Once in, type the word "infra", and then hit ctrl-x. Hit "Y" to save, and you are set!

This may help a lot of home users who often only use one access point, and don't need to look for school servers first.

Reference: http://wiki.laptop.org/go/Network_Configurations

Cheers,

Infamy
1st day donor :)
Infamy
Support Team
 
Posts: 168
Joined: Wed Dec 26, 2007 3:21 pm
Location: Portsmouth, NH

Re: Wifi Connection Cycle Tip

Postby ffm » Wed Feb 13, 2008 5:06 pm

Cool. Thanks for the tip!
OLPC Support Volunteer
ffm
Support Team
 
Posts: 66
Joined: Thu Dec 20, 2007 2:21 pm
Location: Secret Underground Bunker

Re: Wifi Connection Cycle Tip

Postby xook » Wed May 21, 2008 12:23 pm

I tried this a few times but when I typed in the command a text editor did not open, just a long list of commands. When I hit ctrl x; the whole thing just closed up and left me back on the desktop. Now the cycling seems to be happening all at once. The mesh, the internet blinking simultaneously but nothing connecting.

Any suggestions to what I should re look at or re set. Thank you!
xook
 
Posts: 5
Joined: Thu Apr 24, 2008 8:52 pm

Re: Wifi Connection Cycle Tip

Postby ffm » Sun May 25, 2008 2:08 pm

xook wrote:I tried this a few times but when I typed in the command a text editor did not open, just a long list of commands. When I hit ctrl x; the whole thing just closed up and left me back on the desktop. Now the cycling seems to be happening all at once. The mesh, the internet blinking simultaneously but nothing connecting.

Any suggestions to what I should re look at or re set. Thank you!


Try:
Code: Select all
vi /etc/NetworkManager/mesh-start


Then type:
Code: Select all
i
infra
<ESC>
:wq
OLPC Support Volunteer
ffm
Support Team
 
Posts: 66
Joined: Thu Dec 20, 2007 2:21 pm
Location: Secret Underground Bunker

Re: Wifi Connection Cycle Tip

Postby kepstein » Tue Dec 09, 2008 9:50 am

I have created the file, but it isn't apparent that it works. At startup, my XO still appears to look for mesh network first. How can I verify?

Thanks,
Ken
kepstein
 
Posts: 8
Joined: Fri Nov 28, 2008 1:02 pm


Return to Tips, Tricks & Tutorials

Who is online

Users browsing this forum: No registered users and 2 guests

cron