Can't set proxy server in build 650

Discuss solutions for wired and wireless usage for sharing and Internet connectivity.

Can't set proxy server in build 650

Postby JimH » Wed Jan 16, 2008 1:34 pm

Hello,

I too love my XO laptop, but I can't set the proxy server.

I have connected to my wireless access point as described in the wiki, and after I did a shutdown and restart, I was able to browse to the access point and also to a couple of local sites that don't have to go through our proxy server.

I found an article in the wiki that describes how to set the proxy server
/go/Wifi_Connectivity#Proxy_Settings
where the advice is:

Code: Select all
On more recent builds, to change your browser's proxy settings: enter "about:olpc" into the browser's url field. This will load the configuration page for the browser. There are three settings you must change to work with a proxy:
but that doesn't do anything.

My build number is 650, so my browser might be too old for that to work.
Is there a way I can use a terminal to open the configuration page for the browser?

I have read about downloading a new image to install build 653, but that would be very expensive where we are, so I'm hoping for another solution.
Jim
JimH
 
Posts: 1
Joined: Wed Jan 16, 2008 10:42 am
Location: Papua New Guinea

Re: Can't set proxy server in build 650

Postby Guest » Thu Feb 14, 2008 8:27 pm

I think that was just a typo.
Now the referred pages provides the correct information.
http://wiki.laptop.org/go/Wifi_Connecti ... y_Settings
You just need to write about:config (into the address bar of your browser) and hit enter. Now you can scroll down or just filter for "network.proxy.http" double click on the Value column to insert the address of the proxy. Now you just need to set the port in "network.proxy.http_port" and you are ready.

danielfuhry
Guest
 

Re: Can't set proxy server in build 650

Postby Guest » Sat Mar 08, 2008 2:49 pm

I, too, am having problems setting proxy values. I can get to about:config, find the correct lines, but double clicking does nothing. A right click brings up a menu of copy, new and modify commands, with new leading to string, integer and boolean values but all commands are grayed out. Thus I can't put in the proxy values. What am I missing?
Guest
 

Re: Can't set proxy server in build 650

Postby frazras » Thu Dec 11, 2008 7:53 am

Im not using build 650 but i still cant set the proxy in about:config, only the boolean terms can be adjusted
frazras
 

Re: Can't set proxy server in build 650

Postby andydupont » Wed Oct 20, 2010 12:28 pm

I just installed the latest build (852) with firmware Q2E45 on an xo-1.0. I have the same problem trying to change proxy settings using the about:config approach in Browse. It used to work, but no longer.
andydupont
 
Posts: 1
Joined: Wed Oct 20, 2010 12:25 pm


Return to Networking / Internet

Who is online

Users browsing this forum: No registered users and 4 guests

cron