programs "starting..." and never start

Basic questions about your XO? Or search on top right for related questions.

programs "starting..." and never start

Postby BlitheMDJD » Thu Feb 14, 2008 11:39 am

When I start the laptop, any activity (including internet) will not start - it just blinks and says "Starting". I am connecting to wifi and used to be able to start programs and use the internet. This problem started at about the time I got good wifi set up in my home - probably not related. Is there some way to go back to factory settings?
BlitheMDJD
 

Re: programs "starting..." and never start

Postby matt91 » Thu Feb 14, 2008 12:32 pm

I don't have any advice, but I experience a similiar problem too.

If I start Browse first, and then another application they both work fine. However, if I open up another application and then Browse, it will not open....I just get the "starting" issue described above.

Any help on troubleshooting would be appreciated.
Matt
matt91
 
Posts: 52
Joined: Thu Dec 20, 2007 1:40 pm

Re: programs "starting..." and never start

Postby pgh » Wed Feb 20, 2008 2:10 pm

The G1G1 model I gave to my grandchildren is behaving this way. They seem not to be able to start any activity. Unfortunately they live far from me, so I can't observe the behavior. Does anyone know how to fix this?
pgh
 

Re: programs "starting..." and never start

Postby dgrolpc » Mon Mar 10, 2008 6:52 pm

Look at the replies in the post in this part of the forum: "Activities in Build 656 Perpetually Starting..."... you may find some help there.
Email: dgrolpc at [NoSPAM] gmail dot com
dgrolpc
 
Posts: 11
Joined: Sat Feb 02, 2008 4:16 pm
Location: USA

Re: programs "starting..." and never start

Postby tsdguy » Tue Mar 11, 2008 4:11 pm

This is an error in Build 650. A Sugar configuration file gets corrupted causing activities to fail to launch. This info is here in the forum as well as on the wiki. The best way to resolve this is to perform an offline update. This will update the XO to the latest software and firmware overwriting the corrupted files.

Warning - this will ERASE all files on the XO

Here's how to do an offline update. You need a USB Flash drive and another computer connected to the Internet

1. Download these files and copy them to the flash drive
http://download.laptop.org/xo-1/os/offi ... /os656.img
http://download.laptop.org/xo-1/os/offi ... fs2/fs.zip

2. Plug in the XO to AC power and turn it off.
3. Insert the flash drive.
4. Hold all 4 game keys on the right of the laptop (above the power button) and turn on the XO.
5. Release the keys when the screen shows 'release the game keys'.

The laptop will then update itself.

Once this is done, your XO will have release 656 as well as firmware D7.
Foes: kentsin, InterNetZoo
tsdguy
 
Posts: 59
Joined: Fri Feb 01, 2008 1:08 am

Re: programs "starting..." and never start

Postby plym49 » Fri Mar 21, 2008 10:15 am

I am having the same problem. My unit is already at 656. History:

Received recently, so 656 was loaded from the factory. Worked fine standalon but of course would not access WAP. I got WAP to work using a procedure I saw in another post - basically, remoning the network.cfg file and rebooting. This provided WAP access and I was able to get to the internet -- once! As in one web site hit. THe unit would freeze after being booted for a minute or two. It did not matter what app I would start after rebooting, the unit would freeze after a minute or two. It was also throwing a lot of check_node_data errors.

So.....I rebuilt with 656 and D7 again, using a flash drive. The unit came back to life and did not freeze if I started something like Paint. But the first time I started the browser, it froze again. Now, after rebooting, I have programs 'starting' and they never start.

Does anyone have any suggestions? I am quite upset that, after waiting an inordinate amount of time for the G1G1 unit to arrive, this machine has problems handling the most basic operations, and as a result my child is extremely disappointed. Thanks.
plym49
 
Posts: 12
Joined: Fri Mar 21, 2008 9:34 am

Re: programs "starting..." and never start

Postby Wha? » Mon Sep 29, 2008 4:09 pm

I have G1G1 that had the above symptoms, and so I upgraded as described above, and it works now! :D
Wha?
 

Re: programs "starting..." and never start

Postby Guest » Sun Jan 04, 2009 1:01 am

I have a G1G1 laptop and updated the sofwary to the 767 (it originaly had 656). now some activity wont start as described above, but others will. :?:
Guest
 

Re: programs "starting..." and never start

Postby ncarrol » Mon Jan 05, 2009 12:12 am

Guest:

The Upgrade has two parts.

Have you completed the second part: run Update Software in Control Panel (menu under X man) ? If not, you may have old versions of activities.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: programs "starting..." and never start

Postby shonee » Sun Jan 18, 2009 11:16 pm

I recently did a secure update to 767 and since then have not been able to use the Read and Write activities. I did the software update with control panel, and (in an attempt to fix thhe issue) have removed and reinstalled both activities. They just throb for a while then stop without ever launching. Has anyone else had this problem? Other activities seem to work fine. Any suggestions would be appreciated.
shonee
 

Re: programs "starting..." and never start

Postby ncarrol » Mon Jan 19, 2009 1:57 am

Shonee:
How did you do the secure upgrade?
Others (Activities / Software section of forum) have had an activity not starting problem and a clean install solved the problem:

http://wiki.laptop.org/go/Release_notes/8.2.0
See section with XO not connected to internet.

or:
http://wiki.laptop.org/go/No-Fail_Upgrade

This is easy if you have access to a PC connected to the internet and a USB drive. Just click on two links (1/2 hour) and put USB drive in XO and power ON while holding down game keys.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

you must change its ram

Postby thompsonjemss » Mon Feb 16, 2009 6:42 am

Hello Dear


I think you must change it ram, it may be a fault of ram
thompsonjemss
 
Posts: 1
Joined: Mon Feb 16, 2009 6:39 am


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

cron