Updating and Software Builds

Basic questions about your XO? Or search on top right for related questions.

Re: Updating and Software Builds (AC power must be connected)

Postby dwp » Wed Mar 12, 2008 11:46 am

The latest build now appears to be 656. I have installed it on two XOs. I did an update from 650 with the AC Power disconnected. All will go ok to a certain point and then the XO will automatically shut down. If you restart it will provide a message and automatically shut down again. There is a message somewhere in the stream that tells you AC is not connected.

I think the reason may be that the memory is being erased and rewritten with the new build. Should the power fail due to a run down battery, the machine would be (perhaps permanently) dead.
dwp
 

Re: Updating and Software Builds (AC power must be connected)

Postby dbaPlanB » Wed Mar 12, 2008 6:41 pm

To confirm -- I just got my XO today (12 March 2008) and following instructions on this list, found that I have build 656. (I'm trying to get on my WPA wifi network without downgrading the network.)
cheers,
PG

dwp wrote:The latest build now appears to be 656. I have installed it on two XOs. I did an update from 650 with the AC Power disconnected. All will go ok to a certain point and then the XO will automatically shut down. If you restart it will provide a message and automatically shut down again. There is a message somewhere in the stream that tells you AC is not connected.

I think the reason may be that the memory is being erased and rewritten with the new build. Should the power fail due to a run down battery, the machine would be (perhaps permanently) dead.
dbaPlanB
 

Re: Updating and Software Builds

Postby BillWaggener » Fri Jun 13, 2008 5:31 pm

I am getting totally confused by the builds and updates. I had thought that there was to be something called Update 1 when some number of the builds were stable and that an XO would be automatically updated at Update 1. Now I see that the builds are up to 703?, I have 656 and that something called Update 1.1 is coming soon with Update.2 later. In addition there are somethings (versions, I guess) like 8.10. In addition it appears that the updates are OS only and that activities are separated from the OS and are installed separately. I only want to update at major milestones which is what I thought Update 1 is supposed to be. I am somehow missing the big picture. Can someone straighten me out and give some advice as to when I might wish to update and will it ever be "automatic."

Thanks,

Bill Waggener
BillWaggener
 
Posts: 23
Joined: Mon Feb 04, 2008 3:01 pm

Re: Updating and Software Builds

Postby Sarah Elkins » Mon Jun 23, 2008 9:59 pm

I wish they had a more clear roadmap, too. It's my understanding that 703 is Update 1, but it's not being autodeployed because it's a little buggy. Anyone with a better understanding is welcome to speak up.
Sarah Elkins
 
Posts: 83
Joined: Tue Jan 29, 2008 3:04 pm
Location: DC Area, US

Re: Updating and Software Builds

Postby BillWaggener » Tue Jun 24, 2008 1:32 pm

Thanks..I hesitate to update at 703 since it seems to have bugs that my current build doesn't. I also don't really understand the status of activities. I see that some activities don't work under 703.
Bill
BillWaggener
 
Posts: 23
Joined: Mon Feb 04, 2008 3:01 pm

Re: Updating and Software Builds

Postby Karenxo » Sat Jun 28, 2008 8:39 am

I recently updated to Build 703. It was great for a couple of days, but now I am having serious trouble with the web browser. I can't click on more than one link! The first link I click after starting up is fine, but the browser does not respond to any more clicks until (at minimum), I close the browser, disconnect from the wi-fi, and start it up again. Even shutting down/rebooting only gets me back to the same situation.

Also some trouble with ALL CAPS suddenly turning on... not sure if that's a real bug or my adult-sized fingers accidentally hitting the wrong thing as I try, fruitlessly, to click a second link.

Before I revert to the earlier Build, has anyone had this problem and is there a fix? Thank you.
Karenxo
 

Build 703 upgrade: Activity Taskbar is missing

Postby peterladage » Wed Jul 02, 2008 3:11 pm

Hi,

I upgraded from Build 650 to 703 and now the Activity Taskbar is missing. What should I do?
peterladage
 
Posts: 2
Joined: Wed Jul 02, 2008 3:08 pm

Re: Build 703 upgrade: Activity Taskbar is missing

Postby Steve Holton » Wed Jul 02, 2008 4:09 pm

peterladage wrote:I upgraded from Build 650 to 703 and now the Activity Taskbar is missing. What should I do?

I'm guessing you might just be missing the activities, with the Activity Taskbar still being there, just empty.

Sounds like you did this:
http://wiki.laptop.org/go/Activated_Upgrade

Sounds like you need this:
http://wiki.laptop.org/go/OLPC_Update.1 ... Activities
Steve Holton http://wiki.laptop.org/go/Support
Got an XO? Get on the map: http://tinyurl.com/37hmmm
Steve Holton
Support Team
 
Posts: 81
Joined: Thu Dec 13, 2007 7:11 am
Location: North Carolina, USA

Re: Build 703 upgrade: Activity Taskbar is missing

Postby peterladage » Fri Jul 04, 2008 7:33 am

Thanks! That did it!
peterladage
 
Posts: 2
Joined: Wed Jul 02, 2008 3:08 pm

Re: Updating and Software Builds

Postby Lightfoot » Fri Jul 04, 2008 12:56 pm

...recently updated to Build 703. It was great for a couple of days, but now I am having serious trouble with the web browser......Before I revert to the earlier Build, has anyone had this problem and is there a fix? Thank you.....


I upgraded several weeks ago. Read about suspend problems with the energy management program. There is a patch to correct some of the effects. Appears the patch has been working for many and should be added to update in the future. I have not had many problems if I continue to use. I have not installed the patch yet.

I Installed XMMS media player so I can play music while working on my XO. No major problems yet.
Lightfoot
Lightfoot
 
Posts: 3
Joined: Tue Apr 01, 2008 11:34 pm

Re: Updating and Software Builds

Postby KarenXO » Sat Jul 05, 2008 10:02 am

Thank you for the response, Lightfoot. I'm going looking, but in case I don't find it easily, do you know where I can download the patch?
Karen
Proud owner of a G1G1 XO Laptop
KarenXO
 
Posts: 8
Joined: Sat Jun 28, 2008 8:42 am

Re: Updating and Software Builds

Postby Update to 8.2 ! » Thu Nov 20, 2008 5:38 pm

8.2 is out and it is beautiful. Take a look and download it...
http://wiki.laptop.org/go/8.2.0

:mrgreen:
Update to 8.2 !
 

Re: Updating and Software Builds

Postby jimofoz » Wed Nov 26, 2008 12:26 pm

I have to agree. I upgraded to the latest and really like what they added. The control panel is really handy and I've been able to login to WPA wireless with no problems. I used the USB flashdrive upgrade.
jimofoz
 
Posts: 11
Joined: Fri Jan 25, 2008 5:29 pm
Location: Freeland MI

Re: Updating and Software Builds

Postby relativetoo » Sun Nov 30, 2008 12:24 am

I would like to update my xo os to 767 which is the latest release.I would like to do a simple release. I can't tell if my u3 has been uninstalled from my usb drive.when I go to open "MY COMPUTER" and look at the external drive J where my usb drive is located,I see a u3 or usb
.exc. when I click on it there's nothing in it.next to the u3.exc icon is another icon.to
paraphrase the u3.exc icon window message that comes up when you click on it,it says
if you want to install the u3 you can with the second icon.I think it says that.

I need a step by step instructions of
1.) how to tell if the u3 has been uninstalled?
2.) can someone walk me through the downloading of update 767?on the wike page there's too
many instruction for the simple updating,it seems as though instructions start to
merge into other types of offline updating.
3.) If you can't walk me through it,is there someone else that can? I have spoken with
OLPC IRC help, they referred me to the wiki support page.
4.) Once I have the 767 os will this new os allow me to upload pictures to web pages or other?
relativetoo
 

Re: Updating and Software Builds

Postby ncarrol » Sun Nov 30, 2008 4:55 am

The simplest for your situation is to download two files (simply click on the links) to a PC (see reference below). Takes about 1/2 hour.
Then copy the files to your USB drive.
Then follow the step by step instructions given in the section "If you are not connected to the internet" :

http://wiki.laptop.org/go/Release_notes/8.2.0

Briefly, insert USB drive and start the XO while holding down all the game keys on the right side of display (under the speaker).

If your USB drive does not work (U3 issue) then get a cheap 1 gig drive (500 meg will work) at WalMart for about $8. Since you have the files on the PC, it is easy to copy them to a USB drive again.

You can also download the files using the XO browser and from Journal copy/rename(strip off directory part) to USB drive (longer explanation).
The same reference also gives instructions for a direct upgrade over the internet.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

PreviousNext

Return to General Questions

Who is online

Users browsing this forum: hasua and 2 guests