Power light on, but XO won't power up

Basic questions about your XO? Or search on top right for related questions.

Power light on, but XO won't power up

Postby kscott22 » Thu Jan 14, 2010 12:45 pm

I have an XO that was donated to a child I work with. The XO is about a year old, but it's never been used before (I don't even think the box has been opened). I opened it, plugged it in and turned it on. Both the battery and power lights are green, but nothing is happening (screen remains off, adjusting brightness and pressing other buttons on the keyboard do nothing). I tried charging it overnight and unplugging it -- the battery light goes off, while the power light comes on. Still no luck.

Any advice would be much appreciated.
kscott22
 
Posts: 5
Joined: Thu Jan 14, 2010 12:41 pm

Re: Power light on, but XO won't power up

Postby sandy|XO » Thu Jan 14, 2010 7:52 pm

It this XO had been in a box and not used for many months, it is most likely that its internal battery has worn down.

The overall issue and the repair required is detailed here:

http://wiki.laptop.org/go/Fix_Clock

and volunteer repair centers are found here:

http://wiki.laptop.org/go/Directory_of_repair_centers

You can also send a message to help@laptop.org
sandy|XO
 
Posts: 33
Joined: Sat Nov 21, 2009 5:12 pm

Re: Power light on, but XO won't power up

Postby ncarrol » Thu Jan 14, 2010 11:34 pm

Confirm sandy|XO reply.

Here is one version to automatically fix problem. Look at the replies in it.

http://www.olpcnews.com/sales_talk/g1g1/how_to_fix_bricked_g1g1_xo_lap.html

Confirm that repair center approach is your best choice. The largest expense is shipping.

If you are inclined, the manual repair is not too hard, if you can make your own cable. The usb to serial board is about $15 (BOB-00718 from sparkfun.com or similar from mouser.com or any board that uses FT232R chip). Requires USB /micro USB cable (used for some camera to PC) or $4 (CAB-00598) and "make our own" cable from board to XO. Download and unzip the driver from sparkfun to a PC. Plug the USB cable into the PC and a new hardware Wizard will step you through finishing the install. Follow the setup and line commands (using Windows HyperTerminal - in accessories/communications) given in the Fix_Clock link above.

In the end, the repair center is cheaper for a single XO when using US Postal Service Flat rate shipping (all my bubble wrapped shipped XO's have arrived safely).
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Power light on, but XO won't power up

Postby ncarrol » Sun Jan 17, 2010 12:17 am

Update. The above link has a new post.

Apparently the internal RTC clock battery can become discharged, but is rechargeable. It can only be recharged by leaving the XO powered on (eventhough it does not boot) for a couple of hours. Then power off and try starting again.

This will not help if you have the original buggy firmware from 2007/early 2008 or the battery has been jarred from a defective holder.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Power light on, but XO won't power up

Postby asifali418 » Tue Mar 23, 2010 11:55 pm

hello sir i buy brand new aapter for my xo.but its not working
here is the link wich adopter i used.
http://cgi.ebay.com/ws/eBayISAPI.dll?Vi ... K:MEWNX:IT
and i use desktop with window xp pro i download the driver.i used the hyperterminal.but no luck i but 115200 none 8 1 and ox on off.but no luck can u guys tell me what i doing wrong.pls help me
asifali418
 
Posts: 2
Joined: Tue Mar 23, 2010 11:51 pm


Return to General Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron