developer key doesn't work

Basic questions about your XO? Or search on top right for related questions.

developer key doesn't work

Postby tirerim » Thu Jun 24, 2010 6:12 pm

It seems my developer key has stopped working, or the firmware has stopped recognizing it. In any case, I'm not getting the ofw prompt -- it goes straight to the XO icon on startup. The dev key is safely there in /security/develop.sig, and I even redownloaded it to make sure it was correct. Putting it on an SD card (formatted vfat) doesn't seem to do anything either. I know that it used to work, but I'm not entirely sure when it stopped -- it could have when I upgraded to the latest OS and firmware (Q2E41), or it could have been later -- since I hadn't actually used the dev key for anything in a while, and I might not have noticed the lack of the prompt. Any suggestions?
tirerim
 
Posts: 3
Joined: Thu Jan 29, 2009 11:46 pm

Re: developer key doesn't work

Postby sandy|XO » Thu Jun 24, 2010 10:51 pm

Does appear odd that your developer key worked and now doesn't.

Does it make any difference to try with and without the power adapter being plugged in?

Holding down the "check marked" game key on the right while initially powering on will give you a few more seconds to press or tap the "esc" key.

Could the esc key be not working? (Once you get to a prompt you could test-all and try the keyboard thoroughly.)
Sometimes the esc sequence is just finicky...reboot a few times and see if timing works.

Finally, have you disabled security per http://wiki.laptop.org/go/Activation_and_developer_keys
sandy|XO
 
Posts: 33
Joined: Sat Nov 21, 2009 5:12 pm

Re: developer key doesn't work

Postby tirerim » Fri Jun 25, 2010 3:54 am

Aha, holding down the check mark key worked -- thanks! That gave me the same two or three second countdown that it used to display without my doing anything. It's odd that the behavior changed, but maybe that was just something that changed with the latest firmware.
tirerim
 
Posts: 3
Joined: Thu Jan 29, 2009 11:46 pm


Return to General Questions

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron