Speak activity no longer starts

Basic questions about your XO? Or search on top right for related questions.

Speak activity no longer starts

Postby JTR » Sat Aug 07, 2010 4:29 pm

I got one of the original G1G1 OLPCs along with 4 other friends. At first we used and tested them. Then mine sat on shelf until recently when my niece asked if she could have it and I was glad to say yes. First I needed to update it from Build 656 to 802. That went well and was glad to see the new format and features. I specially liked the Speak activity and thought she would really like this.

However, she asked if she could use Skype on the OLPC. After some research I found the steps to load Skype. I did the wget of getskype-linux-beta-fc10 and ran the yum localinstall command. This was not successful. I then noticed some of the activities had problems starting, Speak being one.

So, I used the gamepad O and start procedure to go back to Build 656 which worked. I then again upgraded to 802. This went well but Speak still will not start. Everything else seems to work.

Any suggestions?

Should I do clean install (not an upgrade) of 802 and hope Speak will work again?

Any help will be much appreciated :?:
JTR
 
Posts: 3
Joined: Sat Aug 07, 2010 4:07 pm

Re: Speak activity no longer starts

Postby ncarrol » Sat Aug 07, 2010 8:05 pm

In 802, you might try deleting activity and reloading (Control Panel >Software Update and just check the one activity).

Here is a fix for a sound problem:

http://www.olpcnews.com/forum/index.php?topic=1256.msg32316#msg32316

You can always do a clean install via the USB drive (but lose any data):

http://wiki.laptop.org/go/No-fail_update

Also search on the topic of "alsamix" on this site and on olpcnews.com

I do not have personal knowledge here --- just giving references.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Speak activity no longer starts

Postby ncarrol » Sat Aug 07, 2010 8:37 pm

This recent reference on skype on the XO may be helpful.

http://www.olpcnews.com/forum/index.php?topic=471.msg32267#msg32267
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Speak activity no longer starts

Postby JTR » Sun Aug 08, 2010 5:40 pm

Thank you for your responses. I have erased and reloaded Speak with the same results.

What is interesting is that Speak v9 works fine but Speak v16 that comes with 802 is having the problem. Speak v16 has the interactive speech.

Short of a clean install of 802, is there a way to back out the Skype installation? When I check the log, I find an error OSError: [Errno 17] File Exists: '/home/olpc/isolation/1/uid_to_home_dir/10002/data/.cache.raindbow/oinstall.net/interfaces'

Tried renaming interfaces but then I get a message that it is missing.

Have a feeling I will do a clean install from a usb.

Thanx again
JTR
 
Posts: 3
Joined: Sat Aug 07, 2010 4:07 pm

Re: Speak activity no longer starts

Postby JTR » Sun Aug 08, 2010 8:37 pm

ncarrol, Thanx for your help. I reloaded from scratch using the links you supplied. All works well. Speak is great and I am sure my niece will really like it.

Thanx again. :D
JTR
 
Posts: 3
Joined: Sat Aug 07, 2010 4:07 pm


Return to General Questions

Who is online

Users browsing this forum: No registered users and 3 guests