probem with java and arduino

Basic questions about your XO? Or search on top right for related questions.

probem with java and arduino

Postby ingi » Wed Aug 25, 2010 8:17 am

Hello, I am trying to use my xo laptop to program and controle the arduino open source controle unit.

http://www.arduino.cc/

To do that i needed to install the java software. I followed this instructions

http://wiki.laptop.org/go/RestrictedFormats#Sun_Java

and then these

http://blog.makezine.com/archive/2008/0 ... n_the.html

I can run the adruino software but my xo laptop gives me this message:

./arduino: line 20: java :command not found


What do I do wrong?

Best

Ingirafn
ingi
 
Posts: 1
Joined: Wed Aug 25, 2010 8:11 am

Re: probem with java and arduino

Postby ektoric » Wed Aug 25, 2010 9:45 am

It is unlikely, but possible, that the the java binary is not in your PATH.
1) Try "which java". That command will tell you if the "java" command is in your PATH somewhere.
2) Try "ls /usr/java/jre1.5.0_13/bin/" and see if the "java" command is there. If so, then you can add this directory to your PATH.

But more than likely there was some problem in installing the java RPM. Try reinstalling, making sure it didn't fail because of some dependency.

3) You can try "rpm -qa | grep jre" which will "query all packages in the RPM database, grabbing out names that contain jre" to see if the jre package was installed.
ektoric
Support Team
 
Posts: 470
Joined: Wed Jan 02, 2008 3:46 pm
Location: Austin, TX


Return to General Questions

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron