Getting online with new build using gnome

Basic questions about your XO? Or search on top right for related questions.

Getting online with new build using gnome

Postby neilneil » Sat Jun 11, 2011 12:34 pm

Hi, I recently got the latest build and firmware installed on my xo 1. It looks great, especially the gnome desktop thing for someone like me used to windows. Even has firefox... However, under gnome, how can I connect to the internet? I'm sitting in a place with a wifi connection. Under sugar, just click on the circle and enter the password. Could someone point me in the direction of instructions for connecting under gnome on the xo?

Incidentally, I am also trying to install xo-get (to uninstall activities the easy way - already tried following the instructions for deleting activities the hard way and they are beyond me. I know I'm dumb.) Anyone know how to do that (install xo-get)? I already tried the instructions on the wiki page, but they didn't work. (The "wget www.... part just came up with an error message.)

Finally, has anyone ever got voip to work on the xo? I'd really like to use it to talk to my girlfriend in China using messenger, skype or anything where we can have free calls (I'm in the UK). I tried meebo, but the msn version there only has a little webcam button which never connects. My XO is too full at the moment to install skype (I guess). Just wonder if anyone has ever got something like that to work and could point me to some EASY instructions?

Thanks!
neilneil
 
Posts: 6
Joined: Fri Jun 10, 2011 11:39 am

Re: Getting online with new build using gnome

Postby neilneil » Mon Jun 13, 2011 6:26 am

OK, so as not to waste people's time, I found the uninstall activity option on this build, so that's sorted. I've also installed skype under gnome, so that's kind of sorted.

I still have no idea how to get online (under gnome), so can't test skype. I tried adding a connection, but after filling in all the info (MAC address, password, connection type, etc) I can't click "Apply".

I will keep searching for the answer. In the meantime if anyone sees this post and can help, it would save me a lot of time. Thanks!
neilneil
 
Posts: 6
Joined: Fri Jun 10, 2011 11:39 am

Re: Getting online with new build using gnome

Postby neilneil » Mon Jun 13, 2011 7:08 am

OK, I've tried, I've googled, I've searched the forums both here and at the olpc news forums, and I'm stuck.

I'm in sugar, I'm online, the wireless lights are flashing. I switch to gnome. I start firefox. I'm offline, the wireless lights are off.

What do I do?
neilneil
 
Posts: 6
Joined: Fri Jun 10, 2011 11:39 am

Re: Getting online with new build using gnome

Postby ncarrol » Mon Jun 13, 2011 10:49 pm

Here is info I saved from "help" sources, but I can not find reference.
Apparently the information about connections is not stored when exiting
Gnome/firefox. This makes connections common to sugar and Gnome.
NOTE: I have not tried this !

"Fire up the nm-connection-editor before you reboot, Find the connection
under the wireless tab, tick both "Connect automatically" and "Available
to all users". This creates a file in /etc/sysconfig/network-scripts,
forcing NM to bring up the connection on boot, before the UI loads and
should be available in both Sugar and Gnome. You don't need to go into
gnome to run the tool, in terminal: nm-connection-editor ."

Hope this helps.

Also, I maintain (even though contradicted by others) that most of the problem
with the "jumpy cursor" is due to charge buildup as the finger is rubbed across the
plastic touchpad surface. You can dispel the charge by rubbing together the hands
briskly and touching a large object. A better solution is to tape a metal foil ribbon
from the right side of the right resistance pad and down and under the rubber foot
so the foil rests on the table top. If the cursor starts to jump, touch the foil to dispel
the charge.
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am


Return to General Questions

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron