.XO files won't download or install in Browse in 8.2.0

Talk about how to use and get the most out of Activities for the XO.

.XO files won't download or install in Browse in 8.2.0

Postby gbaird » Mon Nov 17, 2008 1:14 pm

Hi, all. After updating my son's XO with the newest operating system (build 767, sugar 0.82.1, Firmware Q2E18), I am unable to load things from the wiki.laptop.org website by simply clicking on .xo links. When I click on them, nothing happens; no download starts, and no notification of download or option to install comes up across the top of the browser. Prior to the update, this worked just fine. Using firefox (which I was able to install at command line in the new build), I can click on the links and download the files, but nothing happens when I click in browse.

Also, when I try to update software on the control panel, it detects that Browse needs to be updated, but continually fails to update browse from version 86 to 98. I wasn't able to install a new Browse with xo-get (or any other file, though), since I now get "caution: excluded filename not matched: mimetype" errors.

So:
1) Is this a known Browse problem with the new build?
2) Is the xo-get problem new?
2) Can anyone think of what might be wrong or how to fix, outside of a new install of the OS?

Thanks!
Geoff
gbaird
 

Re: .XO files won't download or install in Browse in 8.2.0

Postby AuntiMame » Tue Nov 18, 2008 4:37 pm

Geoff,

You can also install activities from the Journal.

On another computer download the newest Browse http://dev.laptop.org/~erikos/bundles/0 ... owse-98.xo and copy it to a USB stick.
Insert the stick in the XO and then open the Journal.
When the stick is mounted, a USB icon will appear in the bottom left of the Journal. Click on it to open (see the contents) of the stick.
Click on the > symbol in the right column of the .xo file.
A details page will open. Click on the > symbol in the upper right of the screen.

This should install the latest version of Browse. Then try other .xo files from the new version of Browse.

Hope this helps,
Aunti
http://www.XOExplosion.com
Silly name. Great stuff for your XO laptop.
AuntiMame
 
Posts: 65
Joined: Sun Dec 30, 2007 12:24 pm

Re: .XO files won't download or install in Browse in 8.2.0

Postby HoboPrimate » Tue Nov 18, 2008 5:18 pm

gbaird wrote:Hi, all. After updating my son's XO with the newest operating system (build 767, sugar 0.82.1, Firmware Q2E18), I am unable to load things from the wiki.laptop.org website by simply clicking on .xo links. When I click on them, nothing happens; no download starts, and no notification of download or option to install comes up across the top of the browser. Prior to the update, this worked just fine. Using firefox (which I was able to install at command line in the new build), I can click on the links and download the files, but nothing happens when I click in browse.

Also, when I try to update software on the control panel, it detects that Browse needs to be updated, but continually fails to update browse from version 86 to 98. I wasn't able to install a new Browse with xo-get (or any other file, though), since I now get "caution: excluded filename not matched: mimetype" errors.

So:
1) Is this a known Browse problem with the new build?
2) Is the xo-get problem new?
2) Can anyone think of what might be wrong or how to fix, outside of a new install of the OS?

Thanks!
Geoff

This could be an existing open bug, where when having multiple Browse activities opened, these kind of messages appear in the other opened Browse.

With not being able to upgrade Browse, one way you could go around it is by opening the Terminal, and delete the Browse activity, and let Software Update install the recent one afresh. The commands to enter in the Terminal would be:
Code: Select all
cd Activities
rm -rf Browse.activity
HoboPrimate
 
Posts: 44
Joined: Thu Dec 27, 2007 11:45 pm

Re: .XO files won't download or install in Browse in 8.2.0

Postby Guest » Wed Nov 19, 2008 12:14 pm

Reinstalling the operating system (clean install from USB stick) worked just fine, and everything is OK now. Thanks!
Geoff
Guest
 


Return to Activities / Software

Who is online

Users browsing this forum: No registered users and 1 guest