Bug #8834: Activities Fail to Start

Talk about how to use and get the most out of Activities for the XO.

Bug #8834: Activities Fail to Start

Postby xojow » Mon Apr 13, 2009 9:16 pm

I am seeing exactly the behavior described in bug #8834 on dev.laptop.org http://dev.laptop.org/ticket/8834#comment:3 :
The title of the bug is misleading - I didn't remove /etc/olpc-security.

I have a new G1G1 running Build 767, Sugar 0.82.1
Was working fine until a few days ago when I began seeing the following symptom:
Most activites, including Scratch and Browser, will fail to launch. Clicking on the icon the screen shows the large icon for a while. Then about a minute later the large icon goes away and the XO goes back to the home screen. Except, the icon of the activity I tried to launch displays beneath the "XO". If I hover over that icon it says "sugar-shell".

Luckily, I am able to run the Terminal activity and the Control Panel.

I've tried restarting, rebooting, power-cycling. None of these has any effect.

I did not make any modifications to the system. It was working fine until last week.

Help? Any ideas?

Please Cc: replies to joelw@alum.mit.edu.

Thanks

Joel
xojow
 
Posts: 3
Joined: Mon Apr 13, 2009 8:55 pm

Re: Bug #8834: Activities Fail to Start

Postby ncarrol » Mon Apr 13, 2009 10:59 pm

Appears to be corrupted software. Suggest clean install -- don't forget to save any important stuff, such as any developer key.

http://wiki.laptop.org/go/No-fail_update
ncarrol
 
Posts: 367
Joined: Mon Aug 25, 2008 12:38 am

Re: Bug #8834: Activities Fail to Start

Postby xojow » Thu Apr 23, 2009 9:19 pm

Thanks for the suggestion but I would rather pursue less drastic alternatives first if they're available. If anybody else has seen the same problem, maybe someone has found the cause and knows the solution.
xojow
 
Posts: 3
Joined: Mon Apr 13, 2009 8:55 pm


Return to Activities / Software

Who is online

Users browsing this forum: No registered users and 2 guests

cron