Page 1 of 1

VNC Launcher errors

PostPosted: Tue Jun 29, 2010 2:54 pm
by cswisher
I'm trying to run the VNC Launcher activity, and it fails with the following message when I start the X11VNC Server:

Code: Select all
/home/olpc/Activities/VncLauncher.activity/x11vnc: error while loading shared libraries: cannot open shared object file: No such file or directory

I've tried both versions available (for 7.x and 8.x builds), and both have similar errors. Here's my software version info:

Build: 201 customized
Sugar: 0.84.2
Firmware: Q3A33
Wireless Firmware: 9.70.7.p0

Please help!


PostPosted: Wed Jun 30, 2010 3:12 pm
by cswisher
In case anyone else has this issue, I got a thorough workaround from OLPC support (not using the VNC Launcher activity). This worked:

1) Switch from Sugar Learning Platform into GNOME (hover over Sugar's central XO figure -> My Settings -> Switch desktop -> Switch to GNOME)

2) Launch Applications -> System Tools -> Terminal

3) Type "su" and hit enter

4) Type "yum -y install vino" and hit return. You'll need to be connected to the internet.

5) System -> Preferences -> Remote Desktop

6) Check "Allow other users to view your desktop", "Allow other users to control your desktop", uncheck "You must confirm each access to this machine", check "Configure network automatically to accept connections"

7) Switch back to Sugar -- "Switch to Sugar" icon on desktop

8) In Sugar, launch "Terminal" Activity; you will need to click on the "List view" in the top right. Optionally click on the star to the left of Terminal in the List view if you want to add this Activity to your regular "Favorites view"

9) Type "/usr/libexec/vino-server" and hit enter

10) You can now connect to whatever the IP address of the XO is, with a standard VNC client running on any other computer on your local network. (You can find out your XO laptop's IP address with "ifconfig"

Re: VNC Launcher errors

PostPosted: Fri Jul 02, 2010 12:27 am
by sheally