how to install F11 on the XO1?

Discuss Sugar, upgrades and developer perspectives.

how to install F11 on the XO1?

Postby JrGhoull » Sun May 17, 2009 7:09 pm

okay so thanks to Kurt H Maier i have most but not all the instructions (that i need) to install fedora 11 on my xo

heres what i have so far

Step 1:
Right-click and "Save file as" the following two links: ... 090514.crc ... 090514.img

Save them to your usb drive. Turn your XO-1 off. Plug the usb key
into your XO-1 and turn it on.

As soon as you see activity on the screen hit the Escape key (upper
left corner, with an X on it). The XO-1 will say "ok"

you then you type:

copy-nand u:\20090514.img

and press enter.

The XO will write the new image to your drive. You'll see a bunch of
blocks changing color as it does this.

Once it's done writing it'll say "ok" again. You can then turn your
machine off, remove the USB drive, and turn it back on. That should
do it!

as you can see its pretty through, but i'm still having problems. I was having problems downloading the .crc file...but after doing a "save target as" from internet explorer I was able to download all 28.4 kb of that file. right now though I am stuck at step 3. i am hitting (and tried holding down too) the escape key but it doesn't seem to be doing much. when sugar starts loading up and the XO starts drawing a circle made out of dots i get this ^[ when i hold the escape key i know the XO is seeing it...any idea about what to do?

i am using a sandisk 8 gig flash drive for this...i would consider that being the problem but i am able to use it to install the normal sugar distros on it. so i figure that if the regular sugar distros which are made for the XO can be installed off of it, that the specialized f11 can be as well. who knows though...maybe i'm wrong?

anyway, help would be appreciated. when it comes to the step i type that ver batum or do i replace some part of it with...i dunno...the name of my usb or drive letter or something? (no i'm not a noob but i play one in real life...on tv however i'm a cybernetic l33t hacker)
Posts: 2
Joined: Sun May 17, 2009 6:12 pm

Re: how to install F11 on the XO1?

Postby JrGhoull » Thu Sep 17, 2009 1:26 am

copy-nand u:\20090514.img

for step four you enter this exactly as it is above. the only thing that should ever change is the file name. so instead of 20090514 it could be named 20120821.img or abracadabra.img

also it should be noted that in order to get to the ok prompt (which looks pretty similar to the screen you get when you are first turning on the computer or when you are updating the sugar os) instead of holding down the esc. key (which in this case is an x located in the upper left hand corner of the keyboard) hold down the "o" button on the game pad. mind you, i'm not talking the "o" key on the keyboard but on the 4 buttoned game pad that is located on the lower right hand side of the screen.

if this helps anyone, please let me know, as it would feel good knowing that this (albeit measly) effort actually helped someone.
Posts: 2
Joined: Sun May 17, 2009 6:12 pm

Re: how to install F11 on the XO1?

Postby harris » Tue Apr 13, 2010 7:08 am

Yes I have also type copy-nand u:\20090514.img but the image name changed please help me what problem is occurred.How can I solved this problem.please give me suggestion as soon as possible.
Posts: 4
Joined: Tue Apr 13, 2010 2:28 am

Re: how to install F11 on the XO1?

Postby natet128 » Fri Apr 16, 2010 2:19 am

You need to get a devkey and disable security.

Getting a developer key for your running XO laptop

On your XO, open the Browse activity.
There's a "Developer key request" web page on the XO to apply for a key. There are several ways to navigate to this page:
In all builds, you can type file:///home/.devkey.html in the browse location field to get to the request page.
In recent builds (including 8.2.0), "Get a developer key" is at the bottom of the Browse start page.
In older builds (8.1, 703 and higher), click "activities" in the OLPC Library left-hand navigation, click on the sub-menu "find activities", and at the bottom of the page that displays is the "apply for developer key" link. Also, under "books" in the OLPC Library, click on the sub-menu "explore your xo", click "troubleshooting", and under "How do I get a developer key for my laptop" is a link to "submit this form"
In still older builds (7.1, 650, 653, and 656), click on the Library link "other" and then on "about your xo". Click on the "apply for a developer key" link at the very bottom of the page. (You can press the 'check mark' (✓) game key to quickly get to the bottom of the page.)
Follow the directions to apply for a developer key; it should be created in a day or two.
Go back to the request page when your key is ready, and follow the instructions to download your key to your XO.
Once your key has been created, you can return to this page at any time on your XO to re-download it; there will be no further creation delay.
Reboot your XO.
Tip: if the typeface is too difficult to read easily, you can use Browse's Zoom options (in the View menu) to make it larger. Alternatively, you can copy the text and paste it into the Write activity, where you can resize it.
After you get a developer key

Make back up copies!
However you get a key, please make a copy of it on some other computer, one that gets backed up regularly, in case this one is lost. Also, you should copy your developer key to /security/develop.sig on a USB flash drive, if you have one.
Disable the security system
Once you have a developer key and have booted your system using it, it is possible to permanently disable the firmware security system, even if your XO's developer key goes away. If you forget to do this, and you usually run ordinary free software distributions like Debian, Ubuntu, or Fedora on your XO, your XO will at some point refuse to boot.
To will permanently turn off firmware security on your laptop:
Reboot the XO
Press the Esc key during boot to get to the 'ok' prompt.
Type 'disable-security' at the 'ok' prompt and press enter
If disable-security says "Restarting to enable SPI flash writing. Try again after the system restarts.", you'll need to start over with the Esc key again as above. If disable-security says "No wp key", it means that security is already disabled.
When security is disabled, you can still re-enable it for a single boot by pressing the X gamepad key while turning the power on. This is useful to do firmware upgrades from signed builds. It can also help to test secure boot on release candidates.
You can reverse the 'disable-security' command by entering 'enable-security' at the 'ok' prompt.
You can see the raw manufacturing data where the disable-security setting is stored by typing ".mfg-data". See Manufacturing data for details.
Posts: 1
Joined: Fri Apr 16, 2010 2:17 am

Return to Sugar, Linux and System Software

Who is online

Users browsing this forum: No registered users and 2 guests